
Virtual Cell Version 4.0 

Facilitated Calcium Diffusion in the Intestinal Epithelial Cell 

The Virtual Cell tutorial is designed to work in conjunction with the Virtual Cell User Guide.  Although this model is somewhat complex for a 
first time user of the Virtual Cell software, it proves the capabilities of the software.  This tutorial has been designed with the intention that 
you may use it to reproduce this model as your own or load in the public version. If you choose to load the public version, you must first go 
to View>Private Only and make sure this option is not selected. By default it will be selected. Select the Model workspace tab and in the 
Model Database panel go to the tutorial folder and load facilitated_ca_diffusion.   

Physiological Basis 
This model has been developed to study the role of calbindin in facilitated calcium diffusion in intestinal calcium absorption.  Simulations 
also aid in the clarification of calcium steady-state levels within the enterocyte. The simplified model portrays calcium channels at the brush 
border membrane and calcium pumps at the basolateral membrane.  Tight junctions depicted at the apical region of the cell are assumed to 
be completely impermeable to calcium diffusion.  In addition, the model does not account for the paracellular transport of calcium into 
neighboring cells. 
Refer to the Geometry document to preview the experimental image on which the model is based.  A public Geometry document is 
available, epithelial_single, for use in this tutorial. The tutorial begins with defining the biological model and concludes with a spatial 
simulation. 

BioModel 

Cellular Structures 

The software initiates with an undefined BioModel. Select the unnamed compartment once 
with the left mouse button.  The compartment will turn red indicating the selection.  Hold down 
the right mouse button and select Properties.  Enter 'EC', for extracellular, in the text field and 
press OK.   

Select the Feature Tool, , once and then click in the extracellular compartment.  A new 
compartment will appear and an Add New Feature dialog will automatically open.  Type in 'C', 
for cytosol, in the Feature Name text field and type in 'PM' in the Membrane Name field for 
plasma membrane; press Add Feature.   

Select the Feature Tool once again and click in the cytosolic compartment.  Type in 'N', for 
nucleus, in the Feature Name text field and type in 'NM', for nuclear membrane, in the 
Membrane Name text field; press Add Feature to implement the names.   

Molecular Species 
ExtraCellular 

Select the Species Tool  and click once with the left mouse button in the EC compartment to open the Add New Species dialog. Type 
Ca, Calcium, in the text field; press Add to create the Species. 

PlasmaMembrane 

The apical calcium channel is represented as a species on the PlasmaMembrane.  Click once on the Species Tool and click once on the 
PlasmaMembrane.  Create the channel species as described above using CaCh for the name. Use the Species tool again to create the 
basal calcium pump on the PlasmaMembrane, name the pump CaPump.  

Cytosol 

Add the following species to the cytosol compartment; calcium, calbindin, calbindin bound, 
endogenous buffer, and endogenous buffer bound. Calcium was already created, so you can 
use the Copy and Paste command via the right mouse button. Select the Species and go to 
Edit>Copy and then click in the Cytosol compartment and go to Edit>Paste. Continue with 
creating the new species as described before. Use the following names for the new species; 
Calbindin, CaBP, Calbindin bound, CaBPB, Endogenous Buffer, B, Endogenous Buffer 
Bound, CaB. 

Nucleus 

Continue to use the cut and paste feature of the Species Tool to add calcium, calbindin and 
calbindin bound to the nuclear compartment.  At this point you should have generated a model that looks similar to the picture to the right. 

Save the model, if you have not done so already, by going to File>Save As.  



Biochemical Reactions 
PlasmaMembrane 

Select the PlasmaMembrane with the left mouse button. Use the right mouse button to access 
the Reactions submenu.  Arrange the species icons in the Cytosol "C" Column such that each is 

visible.  Select the Flux Tool  and then click once in the PlasmaMembrane "PM" column.  
The Flux Reaction Editor will automatically open. Press Rename to access the FluxReaction 
Name dialog. Enter Ca_channel in the text field; press OK to accept the name and to close the 
window. Click on Change and select calcium as the Flux Carrier and then click OK.  

The software will automatically connect Ca_EC and Ca_C to 
the Flux Icon.  Close the Flux Reaction Editor and use the 
line tool to connect CaCh to the middle of the Flux Icon. You 
will notice the word Catalyst will appear as you make the proper connection. It is important to make this 
connection prior to entering the rate equation otherwise CaCh_PM will be recognized as a parameter 
and not as a membrane species. 

Reopen the Flux Reaction Editor by selecting the Flux icon and then use the right mouse button to 
access the Properties option. Select General mass flux for the Kinetic type. Define J_Ca_channel 
with the following equation: 

(J0*Kc*(Ca_EC-Ca_C)/(Kc+Ca_C)*CaCh_PM) 

Next define the parameters that have been introduced in the rate equation, J0, the flux density of an 
open channel and Kc, the dissociation constant for calcium binding to a channel.  Double click in the 
Expression column for J0 and enter .014.  This number was derived by dividing the 
FluxChannelCoefficient (.14) by the ChannelDensity (10).  Double click the Expression column for 
Kc and enter 0.5 for its expression value. Close the Reaction Editor once you have entered all the 
rate information. 

 

Select the Flux Tool once again and then click in the PlasmaMembrane column. Press Rename and 
name the flux reaction CaPump. Press Change to select calcium as the Flux Carrier.  Once again 
notice the software will automatically connect Ca_EC and Ca_C to the Flux Icon.  Close the Flux 
Reaction Editor and use the line tool to connect CaPump to the middle of the Flux Icon. You will notice 
the word Catalyst will appear as you make the proper connection. Remember it is important to 
make this connection prior to entering the rate equation. If you do not do this, CaPump_PM 
will not be recognized as a membrane species but as a parameter. 

Select General mass flux for the kinetic type. Define J_Ca_Pump with the following equation: 

((Vmax*kP*((Ca_CCa_Rest)/(Ca_C+kP))/(Ca_Rest+kP)*(Ca_C>Ca_Rest))*CaPump_PM) 

Enter -4000 for Vmax, the maximum pump turn over rate. Vmax must be entered as a 
negative value to allow for the flux from the cytosol into the extracellular region. Enter 0.25 for 
kP, the dissociation constant for calcium binding to the pump and 0.1 for Ca_Rest, the 
concentration of calcium at rest.  Dismiss the window once you have entered the Rate 
Equation and Expression values. The above equation was derived in the following manner: 

Flux_Pump - Flux_Leak 
Flux_Pump = Vmax*Ca_C/(Ca_C+kP) 
Flux_Leak = L 
L is found from the balance condition at rest: 
L = Flux_Pump_rest 
L = Vmax*Ca_Rest/(Ca_rest + kP) 
The equations can be combined to yield: 
Vmax(Ca_C/(Ca_C+kP)-Ca_Rest/(Ca_Rest+kP))

 

The equation is then rewritten as above with the condition that it is calculated only 
when Ca_C is greater than Ca_Rest. 

 

 

 



Cytosol 
Select the cytosol with the left mouse button and then use the right mouse button to select Reactions from the menu.  Arrange the species 
so that B, Ca and CaBP are on the left side of the work area and Ca and CaBPB are on the right side of the work area. Click once on the 

Reaction Tool, , and then click once in the middle of the cytosol field.  Use the Line Tool, , to 
connect B to the left side of the Reaction Icon.  Select the Line Tool again to connect Ca to the left side of 

the icon.  Select the Line Tool and connect CaB to 
the right side of the Reaction Icon.   

Select the Reaction Icon and use the right mouse 
button to access the Properties option and open the 
Reaction Kinetics Editor. Press Rename to name the 
reaction CalciumBuffer>BoundCytosol.  Select Mass 
Action for the Kinetic Type.  Type in 0.1 for the 
Forward Rate and type in 1.0 for the Reverse 
Rate. Close the window. 

Select the Reaction Icon once again and then click in 
the center of the Cytosol field.  Use the Line Tool, 
selecting it each 
time, to connect 
Ca and CaBP to the left side of the icon and CaBPB to the 

right side of the icon. 

Select the Reaction Icon and use the right mouse button to access the Properties option. Press Rename to name the reaction 
CalciumCalbindin>BoundCytosol. Select Mass Action for the Kinetic Type.  Enter 20.0 for the Forward Rate and enter 8.6 for the Reverse 
Rate. Close the window. 

NuclearMembrane 
Select the NuclearMembrane with the left mouse button 
and then use the right mouse button to select 
Reactions. Once again arrange the species such that each is visible.  Set up three flux reactions; 
calcium, calbindin bound and calbindin.  Select the Flux Icon and click once in the NM column.  
The Flux Reaction Editor will open automatically. Press Rename to name the flux Calcium. Press 
Change to select calcium for the Flux Carrier. The software will automatically connect Ca_C and 
Ca_N to the Flux Icon. 

Select General Mass Flux for the kinetic type and define the flux, J_Calcium, with the following 
equation: (Pcalcium*(Ca_C-Ca_N)).  Double click the expression text field for Pcalcium, the 
permeability coefficient for calcium, enter an expression value of 150.0. Dismiss the window once 
you have entered the Rate Equation and Parameter Expression. 

Next, add a Flux Icon in the NuclearMembrane column for Calbindin.  Select the reaction 
icon and use the right mouse button to go to Properties>Flux Reaction Editor. Rename the 
flux reaction, Calbindin, and then select Calbindin as the Flux Carrier. Select General mass 
flux for the kinetic type and enter the following flux equation to define J_Calbindin: 
(Pcalbindin*(CaBP_C-CaBP_N)).  Double click the Expression field for Pcalbindin, the 
permeability coefficient for calbindin; enter 30.0. Dismiss the window once you have entered 
the rate equation. 

 

Finally, set up the flux reaction for 
CalbindinBound.  Click once on the Flux 
ux Reaction Editor opens, rename the Flux

Reaction, CalbindinBound, and select CalbindinBound as the Flux Carrier. Select Gener
mass flux and enter the following flux Equation to define J_CalbindinBound: 
(Pcalbindin_bound*(CaBPB_C-CaBPB_N)). Double click the Expression text field fo
Pcalbindin_bound, the permeability coefficient for calbindin bound, enter 30.0 for an 
expression value; dismiss the window. 
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Nucleus 
Select the nuclear compartment with the left mouse button and then use the right mouse 
button to select the Reactions option.  Arrange the species such that CaBP and Ca are on 
the left side of the window while CaBPB is on the right side of the window.  Click once on 
the Reaction Tool and then click once in the Reactions for Nucleus dialog placing the icon 
in between the species. Use the Line Tool to connect CaBP and Ca to the left of the icon 
and CaBPB to the right of the icon. 

Select the Reaction Icon and use the Properties option to access the Reaction Kinetics 
Editor. Press Rename and name the reaction CalciumCalbindin>BoundNucleus. Select 
Mass Action for the Kinetic Type.  Enter 20.0 for the Forward Rate and 8.6 for the Reverse 
Rate. Dismiss the window once you have entered the rates. 

The BioModel is now complete.  Resave your model and proceed 
to the Geometry section. 

Geometry 

Generation of Image for Experimental Geometry 

Intestinal Epithelial Cells (Courtesy of Vanderbilt University Medical Center) and Experimental Segmented Image 

       

A portion of the image was used as the 
basis for producing the experimental 
geometry in this spatial simulation model. 
The image was slightly modified to 
contain clearly defined extracellular 
regions between neighboring cells.  It 
was converted into a grayscale image 
and segmented into three distinct 
regions, or compartments, represented 
by three different pixel intensities, 
extracellular, cytosol and nucleus.  The 
image was saved as a 'gif' file and stored 
locally until it was introduced into the 
public Geometry’single_epithlial. 

 
Loading the Geometry Document  

In the BioModel document, go to File>Open>Geometry>Geometry 
Neighborhood>tutorial>epithelial_single. The Geometry document will load with the 
experimental image displayed. 

The image is displayed with three distinct compartments. The image size should be 
17.0, 62.1, and 1.0 in the 'x,y, and z' image planes.  If the image size is incorrect, click 
on Change domain and enter 17.0 for 'x' and 62.1 for 'y'. ‘Z’ should default to 1.0 since 
it is a single image slice. 

 

 

 

 

Application 

The Application is found on the Application panel of the BioModel document. 



Loading the Stored Application   

Select the Spatial Application once and go to Application>Open, or simply double click the Spatial Application. The Application dialog will 
open with the appropriate Geometry loaded and mapped according to the described BioModel. Continue with Structure Mapping below. 

Creating a New Application   

In the Application panel, press Application>New. Supply a name in the dialog; press OK. By default a Compartmental model is mapped to 
the BioModel. Press View/Change Geometry>Change Geometry. In the Geometry Neighborhood go to the tutorial folder and select 
epithelial_single. 

Structure Mapping 

Once you have loaded the Geometry, a cartoon representing the Geometry as described in the BioModel and 
the Geometry image are displayed in Structure Mapping.  You must manually map the Physiology structures 
to the Geometric subdomains using the Line Tool.  You must reselect the Line Tool each time you map a new 
Structure to its Subdomain.   

First map ExtraCellular, then Cytosol and finally Nucleus to its corresponding Subdomain.  In this model each 
structure is spatially resolved.  Membranes do not have to be physically mapped.  This is performed 
automatically in the software as neighboring compartments are mapped.  The surface to volume ratio and the 
volume fraction are not specified since they are resolved in the experimental geometry.  You have to supply 
this information only if the structure is distributed. 

 

Boundary Conditions 

Select ExtraCellular and press Set Boundary Types. 

 

 

 

 

 

 

Select Cytosol and press Set Boundary Conditions. Change X- and X+ to Flux. 

 

Initial Conditions 
In this section you will specify Default Concentrat
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geometry and press OK.  Double click the Initial Conditions column for CaPump_PM; enter the equation (y>=57.59) and press OK. This 
defines the pump regions within the geometry. 

Cytosol 

Enter the following values for the cytosolic species as you did for the previous species. 

Species Concentration Diffusion Rate 
Calcium 0.1 300 
Calbindin 202.83 60 
Calbindin Bound 47.17 60 
Buffer 396.04 0.0 
Buffer Bound 3.96 0.0 
 

Nucleus 

Enter the following values for the nuclear species. 

Species Concentration Diffusion Rate 
Calcium 0.1 300 
Calbindin 202.83 60 
Calbindin Bound 47.17 60 
 

You do not have to enter anything in the Boundary Condition text fields. When the text fields are left blank it will default to the information 
entered in the Initial Conditions. 

(Note: You may initially run this model with the Ca_EC concentration at 1mM as described above. This will represent a steady state model. 
Once that simulation is complete, you may change the concentration to 10 mM and continue to run the simulation until a new steady state is 
achieved. The equation for such a condition would be entered as: ((10000.0*(y<0.89))+(1000.0*(y>=.89))).) 

Reaction Mapping 

Select Fast Kinetics for the three reactions: CalciumCalbindin>BoundCytosol, 
CalciumCalbindin>BoundNucleus and CalciumBuffer>BoundCytosol.  

Resave your BioModel at this point and proceed to Simulation. 

 

Simulation 

You can load the simulation results, from the Simulation tab, or create your own simulation. If you choose to use the simulation and results 
that are there, it is still recommended to follow the remainder of the tutorial so you will familiarize yourself with the software. 

Using the Saved Simulation 

Select the simulation in the Simulation panel and press Edit. See Parameters below for more information. 

Creating a New Simulation 

Press New in the Simulation dialog, a default simulation will be created. Double click the Simulation Name text field to enter the name. You 
can enter descriptive notes about the simulation in the Comments section, under the Simulation Summary.  Press Edit to access the 
additional run conditions for the simulation. 

Parameters 

Select the Parameters tab. You can change the initial values of the parameters 
by double clicking in the Actual Value column for the particular Parameter. Type 
in a value and either press Enter or change your selection. Note, values that 
have changed from the original value show up in red text. For the initial 
simulation you will not make any changes here. 

Mesh 

Select the Mesh tab. The Mesh tab lists the 
Geometry size in microns and the Mesh 
size in elements. By default, the Mesh Size 
is equal to 37 X 135 pixels. Double click in 
the X and Y text fields and change the 



mesh size to 39 x 140.  

The mesh size is larger than the actual image size. This is done to ensure that a full mesh element is captured during the calculations 
instead of half of a mesh element. The Geometry size is obtained from the segmented image that was entered into the Virtual Cell image 
database. This size cannot be edited here. 

Task 

Select the Task tab. Leave the Start Time at 0, change the Time Step to .001 
and End Time to 15. Change the save interval to Keep every 100 time 
samples.  

You can press OK at the bottom of the dialog at this point. You do not have to 
worry about the Advanced tab for this example. The Advanced tab offers 
additional options for ODE solvers, as well as some additional features for 
PDE simulations, but for this example you will not use them. 

You are ready to run a simulation at this point. Make sure the simulation is still selected, and then press Run to start the simulation. The 
software will automatically resave the BioModel and initiate the simulation. As the simulation runs, the Results button will become enabled. 
Press the button to see the results that have been generated thus far. Alternatively you can wait until the simulation is complete and the 
Results dialog will open automatically. 

See Chapter 8 of the User Guide for more information about viewing simulation results. 

 

 

 

 

 

 


