User:Steven J. Koch/Notebook/Kochlab/2009/06/18/More Feedback96

From OpenWetWare

< User:Steven J. Koch | Notebook | Kochlab | 2009 | 06 | 18
Revision as of 19:23, 18 June 2009 by Steven J. Koch (Talk | contribs)
(diff) ←Older revision | Current revision (diff) | Newer revision→ (diff)
Jump to: navigation, search

Steve Koch 17:23, 18 June 2009 (EDT): Wanting to continue my momentum on the piezo issues.

Contents

Need to replace the saving of Piezo info

Image:Piezo Info Saving.png I will just replace this VI with a new one that uses "Default Values."

Steve Koch 18:07, 18 June 2009 (EDT): Done. Reworked "Feedback0B-Incremental Store Segment Information_mx.vi" I didn't use default values, because it was already set up to do key by key. I don't think any of the info was ever used and I saw a bug in that the device wasn't recorded

Ridding other feedback modules of old piezo stuff

Hold & Take Data, etc. All are done except Force Clamp Piezo, Velocity Clamp Piezo, and Loading Rate Clamp. I'm deleting the Loading Rate Clamp, since I think it's the out-dated version that never worked. I believe the loading rate clamp I used is within the VC.

OK, Think I finished with Piezo stuff. Now looking at a bunch of other bugs in Feedback96

Interstep timing

This VI had a bunch of bad linkages. Also some confusing connections. Right now, I'm worried about the "base address".

Steve Koch 19:02, 18 June 2009 (EDT): I think I need to rewire interstep timing to accept the entire DAQmx cluster. The way I'm doing it now is inefficient. Image:Interstep timing.png

Compiles w/o errors!

http://kochlab.org/files/Software/Feedback96--First%20version%20that%20compiles I think this is a major stepping stone. Next step:

  • See if basic feedback program can work (e.g. piezo sweep)
Personal tools