Jones Lab:Protocols:Kup

From OpenWetWare

Jump to: navigation, search

Contents

Photek Luciferase imaging


To capture data

  1. Focus camera in brightfield mode- I do this in the dark, with the door open. Remember to set gains high!
  2. Click 'Run TSI' from Circadian toolbar
  3. Change settings as appropriate- time is in seconds- Remember to save the TRI file, set ND filter to 100% (ie. no filter)
  4. Once data collection is complete load TRI from menu -Click first file in sequence
  5. Check overview of data using CRT (TRI -> Show Count Rate Trend)

To create a sequence file

  1. Click on 'Load frames' on Circadian toolbar
  2. Choose first image in folder
  3. Open into a buffer
  4. Doubleclick to open buffer

To annotate image with OAPs

Right click to cancel at any time

  1. Click 'Circle OAP'
  2. Tap on image to add OAP
  3. Resize to suit
  4. Click to confirm size
  5. Click to confirm position
  6. Label
  7. Copy using copy command

To extract data

  1. Click 'Extract OAP' command on circadian toolbar- Make sure selection = all frames (eg. selection 1-48)
  2. Export to Excel

Andor Luciferase imaging


To capture data

  1. Load Micromanager (Select Main Config Jan 2015 as configuration option)
  2. Set lights as required using pull down menu and dimmer switches
  3. Turn off LEDs and room light- I do this in the dark, with the box door open.
  4. Click 'Live' on Micromanager window, and focus.
  5. Stop live imaging
  6. Open Script panel (Tools...>Script Panel)
  7. Select program you want to run (Red, Blue, Red+Blue or Dark)
  8. Hit 'Run'
  9. Come back to save your file after data collection

Analysing Andor data

Using Maloof lab method (Copied from [1])

Things to do only the first time

  1. Install ImageJ from http://rsb.info.nih.gov/ij/
  2. Install the Multi Measure plugin from http://www.optinav.com/imagej.html
  3. Start ImageJ
  4. You may want to increase the memory allocated to ImageJ: Edit>Options>Memory
  5. Install the circle tool: Plugins>Macros>Install>Tools>CircleTool.txt. (This will need to be done every time you start the program. If you want it loaded by default see instructions for start-up macros in the macros pulldown menu, or on the imageJ website).

To measure intensity

  1. Import your images. File>Import>Image Sequence. You can use the slider bar on the bottom to move through the stack. Also check the the other functions available in Image > Stacks.
  2. Change the LUT. Image>Look Up Tables>Fire (or whatever you like).
  3. Change the scale to pixels. Analyze>set scale. Set Distance in pixels and Known Distance to 1. Set Unit of Length to pixels. IF you click the global box, these settings will be applied to any additional images that you open in this session. You will need to do this for each session.
  4. Go to Analyze>Set Measurements and select Integrated Density as your measurement.
  5. Click on the circle tool on the tool bar (probably the rightmost tool; the icon is a circle drawn in blue, (not an oval in black). Experiment with the correct setting for the radius (by double clicking in the icon in the tool bar) to make an appropriately sized selection.
  6. Start the multi measure plugin Plugins>multi measure.
  7. Click on a plant. Press space. Click on the next plant. Press space. etc.
  8. Select all ROIs from the multi measure window. click Multi in the multi measure window. Copy and paste the results into excel.
  9. To create a key: click label all ROIs. YOU DO NOT WANT TO DO THIS BEFORE CLICKING MULTI, BECAUSE THE LABELS WILL BE PART OF THE IMAGE AND GET COUNTED. You can then save this top slice as a jpg file. (If you choose to save as tiff, the whole stack will be saved as a multi-image tiff).
  10. As an alternative to 9, if you can discard the information on your first slice, then when selecting plants, press "return" instead of "space"...this will draw the ROI. I often duplicate the first slice for just this purpose. If you decide to do this, remember to discard the first row of the results.

Calculate Circadian Rhythms Using BRASS

  1. Find a PC running BRASS
  2. Open BRASS template
  3. Open your data file
  4. Make sure you have the correct ZT values for your data
  5. BRASS > Import > Custom Data > Single Worksheet
  6. Read Genotype and ZT values from the appropriate rows and columns
  7. Time format is 'Time since start in hours'
  8. When prompted, save your imported data
  9. When prompted, derandomize your data
  10. When prompted DO NOT perform analysis, instead click 'No'
  11. BRASS > Analysis > Normalize data
  12. IF analyzing DF data also BRASS > Analysis > Detrend > *Choose File* > Amplitude and Baseline
  13. BRASS > Analysis > Create Files and run FFT-NLLS > *Choose normalized (and detrended if DF) file*
  14. Grab a coffee
  15. Go through .cmd tabs (in Excel sheet) and put an 'x' in rows where Rel-Amp > 0.6
  16. For each genotype, BRASS > Statistics > RAEWtdMean
  17. Save file, draw graphs, etc
Personal tools