Maloof Lab:ImageJ analysis

From OpenWetWare

Jump to: navigation, search

Image:logo2_final.jpg

Room 2115
Section of Plant Biology
1002 Life Sciences, One Shields Ave.
University of California Davis
Davis, CA 95616

Contact

Home      Research      Publications      Protocols      Resources      Announcements      Lab Safety     

Analyzing camera experiments with ImageJ



Things to do only the first time

  1. Install ImageJ from http://rsb.info.nih.gov/ij/
  2. Install the Multi Measure plugin from http://www.optinav.com/imagej.html
  3. Start ImageJ
  4. You may want to increase the memory allocated to ImageJ: Edit>Options>Memory
  5. Install the circle tool: Plugins>Macros>Install>Tools>CircleTool.txt. (This will need to be done every time you start the program. If you want it loaded by default see instructions for start-up macros in the macros pulldown menu, or on the imageJ website).

To measure intensity

  1. Import your images. File>Import>Image Sequence. You can use the slider bar on the bottom to move through the stack. Also check the the other functions available in Image > Stacks.
  2. Change the LUT. Image>Look Up Tables>Fire (or whatever you like).
  3. Change the scale to pixels. Analyze>set scale. Set Distance in pixels and Known Distance to 1. Set Unit of Length to pixels. IF you click the global box, these settings will be applied to any additional images that you open in this session. You will need to do this for each session.
  4. Go to Analyze>Set Measurements and select Integrated Density as your measurement.
  5. Click on the circle tool on the tool bar (probably the rightmost tool; the icon is a circle drawn in blue, (not an oval in black). Experiment with the correct setting for the radius (by double clicking in the icon in the tool bar) to make an appropriately sized selection.
  6. Start the multi measure plugin Plugins>multi measure.
  7. Click on a plant. Press space. Click on the next plant. Press space. etc.
  8. Select all ROIs from the multi measure window. click Multi in the multi measure window. Copy and paste the results into excel.
  9. To create a key: click label all ROIs. YOU DO NOT WANT TO DO THIS BEFORE CLICKING MULTI, BECAUSE THE LABELS WILL BE PART OF THE IMAGE AND GET COUNTED. You can then save this top slice as a jpg file. (If you choose to save as tiff, the whole stack will be saved as a multi-image tiff).
  10. As an alternative to 9, if you can discard the information on your first slice, then when selecting plants, press "return" instead of "space"...this will draw the ROI. I often duplicate the first slice for just this purpose. If you decide to do this, remember to discard the first row of the results.
Personal tools